Posted in | 7 Responses
Sandip Dedhia

Sandip Dedhia

Sandip Dedhia is the founder of Blogsdna.com, he loves to write on technology, gadgets & web services. At Blogsdna you can read his Windows & freeware software related articles. He is on twitter too @sandipnd View author profile

  • iphone 3g owner!

    sweeeeetttt:):P finally

  • mike

    can someone please tell me if i can use the unlock on my iphone 3g version 4.0.1 baseband 05.14.02 ??? the part im worried about is my version 4.0.1.. can i leave what version ? because my itunes will o nly let me update to 4.2 and i dont want to risk updating.
    someone plz reply! thank you!

  • Anonymous

    Till now… no. But because you baseband.

    I’m now with a device with JB working perfectly, buuut… locked because it’s os 05.14.02 baseband.

    Waiting for tomorrow! :D

  • Hotrcold2003

    i have iphone 3gs 4.1,5.14.02….i want to unlock it…. please help me

  • Jeremiah_onan

    can someone please help me out i have a iphone 3gs version 4.0.1 and baseband 05.14.02 i need to unlock it it has already been jb i took it to a guy yesterday which was on 12/16/2010 and he said there was no unlock for it yet but im reading on here where it is a unlock for it so please what do i need to do thanks you can email me at jeremiah_onan@yahoo.com thanks

  • Jeremiah_onan

    can you help me to unlock my iphone im having lots of trouble trying to find a unlock solution thanks if you can

  • Djmjk

    how you do that can you help me